BoundingBoxContainsPointFilter(XYZ, Boolean) Constructor

BoundingBoxContainsPointFilter(XYZ, Boolean) Constructor

Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public BoundingBoxContainsPointFilter(
	XYZ point,
	bool inverted
)
Public Sub New ( 
	point As XYZ,
	inverted As Boolean
)
public:
BoundingBoxContainsPointFilter(
	XYZ^ point, 
	bool inverted
)
new : 
        point : XYZ * 
        inverted : bool -> BoundingBoxContainsPointFilter

Parameters

point  XYZ
The point used to find elements with a bounding box containing it.
inverted  Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also