Revit 2025.3 API
DocumentGet |
Gets the default family type id with the given family category id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId GetDefaultFamilyTypeId( ElementId familyCategoryId )
Public Function GetDefaultFamilyTypeId ( familyCategoryId As ElementId ) As ElementId
public: ElementId^ GetDefaultFamilyTypeId( ElementId^ familyCategoryId )
member GetDefaultFamilyTypeId : familyCategoryId : ElementId -> ElementId
Parameters
- familyCategoryId ElementId
- The family category id.
Return Value
ElementIdThe default family type id.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also