DimensionSegment Class

DimensionSegment Class

A segment of a dimension within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBDimensionSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DimensionSegment : APIObject
Public Class DimensionSegment
	Inherits APIObject
public ref class DimensionSegment : public APIObject
type DimensionSegment = 
    class
        inherit APIObject
    end

The DimensionSegment type exposes the following members.

Properties
 NameDescription
Public propertyAboveThe text shown above the segment's value.
Public propertyBelowThe text shown below the segment's value.
Public propertyIsLocked Indicates if this segment is locked.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyLeaderEndPositionThe position of the dimension leader end point.
Public propertyOrigin The segment origin.
Public propertyPrefixThe text shown before the segment's value.
Public propertySuffixThe text shown after the segment's value.
Public propertyTextPositionThe position of the dimension text's drag point.
Public propertyValue The length of the segment.
Public propertyValueOverrideThe text that replaces the segment's value.
Public propertyValueString The displayed value shown for the dimension segment.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsTextPositionAdjustableIndicates if this dimension is supported to set/get TextPosition/LeaderPosition.
Public methodResetTextPositionResets the text position of the segment to the initial position determined by its type and parameters.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also