Revit 2025.3 API
Dimension |
The position of the dimension leader end point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ LeaderEndPosition { get; set; }
Public Property LeaderEndPosition As XYZ Get Set
public: property XYZ^ LeaderEndPosition { XYZ^ get (); void set (XYZ^ value); }
member LeaderEndPosition : XYZ with get, set
Property Value
XYZ
Exception | Condition |
---|---|
ApplicationException | Thrown when the dimension text is unavailable. |
InvalidOperationException |
Thrown when:
|

This property is not applicable to all dimensions. For example, it is not available for spot dimensions, dimensions using equality formula, and when dimension style is ordinate.
If the position is not applicable, this property returns NULL and will not allow setting a value.
See Also