Revit 2025.3 API
DocumentIs |
Checks whether the GUID is valid for the given document. Empty GUID is allowed.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsValidVersionGUID( Document document, Guid versionGUID )
Public Shared Function IsValidVersionGUID ( document As Document, versionGUID As Guid ) As Boolean
public: static bool IsValidVersionGUID( Document^ document, Guid versionGUID )
static member IsValidVersionGUID : document : Document * versionGUID : Guid -> bool
Parameters
- document Document
- Target document.
- versionGUID Guid
- The GUID to check.
Return Value
BooleanTrue if the GUID is valid.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also