Revit 2025.3 API
Conceptual |
Get the ConceptualSurfaceType by its mass subcategory id.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ConceptualSurfaceType GetByMassSubCategoryId( Document cda, ElementId massSubCategoryId )
Public Shared Function GetByMassSubCategoryId ( cda As Document, massSubCategoryId As ElementId ) As ConceptualSurfaceType
public: static ConceptualSurfaceType^ GetByMassSubCategoryId( Document^ cda, ElementId^ massSubCategoryId )
static member GetByMassSubCategoryId : cda : Document * massSubCategoryId : ElementId -> ConceptualSurfaceType
Parameters
- cda Document
- The document.
- massSubCategoryId ElementId
- The mass subcategory id to get the ConceptualSurfaceType for.
Return Value
ConceptualSurfaceTypeReturns ConceptualSurfaceType associated with input id or NULL.

Exception | Condition |
---|---|
ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassShade, OST_MassGlazing, OST_MassSkylights, or OST_MassOpening. |
ArgumentNullException | A non-optional argument was null |
See Also