Revit 2025.3 API
Lighting |
Provides access to the Lighting Device in Autodesk Revit MEP.

SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBMEPModel
Autodesk.Revit.DB.ElectricalLightingDevice
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBMEPModel
Autodesk.Revit.DB.ElectricalLightingDevice
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The LightingDevice type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|

The Lighting Device object can only be queried in Autodesk Revit MEP.
See Also