Revit 2025.3 API
Lighting |
Provides access to the Lighting Device in Autodesk Revit MEP.

SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBMEPModel
Autodesk.Revit.DB.ElectricalLightingDevice
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBMEPModel
Autodesk.Revit.DB.ElectricalLightingDevice
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The LightingDevice type exposes the following members.

Name | Description | |
---|---|---|
![]() | ConnectorManager |
Retrieves the Connector Manager from this MEPModel.
(Inherited from MEPModel) |
![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject) |
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from MEPModel) |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetAssignedElectricalSystems |
Retrieves the electrical systems this electrical panel currently is assigned to.
(Inherited from MEPModel) |
![]() | GetElectricalSystems |
Retrieves the electrical systems that are currently created using this MEPModel.
(Inherited from MEPModel) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

The Lighting Device object can only be queried in Autodesk Revit MEP.
See Also