Revit 2025.3 API
MEPModel Class |
Supports all MEP models that are persistent within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The MEPModel type exposes the following members.

Name | Description | |
---|---|---|
![]() | ConnectorManager | Retrieves the Connector Manager from this MEPModel. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | GetAssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. |
![]() | GetElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. |
See Also
Reference