SymbolGeometryId Class

SymbolGeometryId Class

This class is used to identify a piece of geometry managed by a symbol element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSymbolGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SymbolGeometryId : IDisposable
Public Class SymbolGeometryId
	Implements IDisposable
public ref class SymbolGeometryId : IDisposable
type SymbolGeometryId = 
    class
        interface IDisposable
    end

The SymbolGeometryId type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertySymbolId The id of the symbol which contains the shared geometry.
Top
Methods
 NameDescription
Public methodAsUniqueIdentifier Returns a string suitable to determine if two instances point to the same piece of geometry managed by the same symbol element.
Public methodDisposeReleases all resources used by the SymbolGeometryId
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This class can be used to compare if two instances points to the same piece of geometry managed by a symbol element. The string returned by AsIdentifier can be used to achieve this.
See Also