ClosestPointsPairBetweenTwoCurves Class

ClosestPointsPairBetweenTwoCurves Class

This class captures results of computation of closest points between two generic curves.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBClosestPointsPairBetweenTwoCurves

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ClosestPointsPairBetweenTwoCurves : IDisposable
Public Class ClosestPointsPairBetweenTwoCurves
	Implements IDisposable
public ref class ClosestPointsPairBetweenTwoCurves : IDisposable
type ClosestPointsPairBetweenTwoCurves = 
    class
        interface IDisposable
    end

The ClosestPointsPairBetweenTwoCurves type exposes the following members.

Constructors
 NameDescription
Public methodClosestPointsPairBetweenTwoCurves Obtain a new instance of ClosestPointsPairBetweenTwoCurves class.
Public methodClosestPointsPairBetweenTwoCurves(ClosestPointsPairBetweenTwoCurves) Creates a copy of the ClosestPointsPairBetweenTwoCurves.
Top
Properties
 NameDescription
Public propertyDistance Distance from point on first curve to the point on second curve.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyParameterOnFirstCurve 1d raw (not normalized) parameter of the point on the first curve.
Public propertyParameterOnSecondCurve 1d raw (not normalized) parameter of the point on the second curve.
Public propertyXYZPointOnFirstCurve Point on the first curve in 3d coordinates.
Public propertyXYZPointOnSecondCurve Point on the second curve in 3d coordinates.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ClosestPointsPairBetweenTwoCurves
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also