FamilyManager.CurrentType Property

FamilyManagerCurrentType Property

The current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public FamilyType CurrentType { get; set; }
Public Property CurrentType As FamilyType
	Get
	Set
public:
property FamilyType^ CurrentType {
	FamilyType^ get ();
	void set (FamilyType^ value);
}
member CurrentType : FamilyType with get, set

Property Value

FamilyType
Remarks
Only the current family type is editable using the methods in FamilyManager. If you want to modify the properties of any family type, it must be set to be the current type first. This value will be if there is no type in the family. In order to modify parameter values, you will need to create one using NewType(String).
See Also