FamilyManager Class

FamilyManager Class

The family manager object to manage the family types and parameters in family document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBFamilyManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FamilyManager : APIObject
Public Class FamilyManager
	Inherits APIObject
public ref class FamilyManager : public APIObject
type FamilyManager = 
    class
        inherit APIObject
    end

The FamilyManager type exposes the following members.

Properties
 NameDescription
Public propertyCurrentTypeThe current family type.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyParameterBuiltInParameterObtains the parameter of this type with a given parameter id.
Public propertyParameterDefinitionObtains the parameter of this type with a given definition.
Public propertyParameterGuidObtains the parameter of this type with a given GUID for a shared parameter.
Public propertyParameterStringObtains the parameter of this type with a given name.
Public propertyParametersAll family parameters in this family.
Public propertyTypesAll family types in the family.
Top
Methods
 NameDescription
Public methodAddParameter(ExternalDefinition, ForgeTypeId, Boolean)Add a new shared parameter to the family.
Public methodAddParameter(String, ForgeTypeId, Category, Boolean)Add a new family type parameter to control the type of a nested family within another family.
Public methodAddParameter(String, ForgeTypeId, ForgeTypeId, Boolean)Add a new family parameter with a given name.
Public methodAssociateElementParameterToFamilyParameterAssociates or disassociates the element parameter to an existing family parameter.
Public methodCanElementParameterBeAssociatedIndicates if this element parameter can be associated with a family parameter.
Public methodDeleteCurrentTypeRemove the current family type.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAssociatedFamilyParameterGets the associated family parameter of an element parameter.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetParameterObtains the family parameter with the given built-in parameter identifier.
Public methodGetParameters Gets the parameters associated to family types in order.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsParameterLockable For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
Public methodIsParameterLocked For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
Public methodIsUserAssignableParameterGroup Checks if the given parameter group can be assigned to new parameters.
Public methodMakeInstanceSet the family parameter as an instance parameter.
Public methodMakeNonReportingSet the reporting family parameter as a regular/driving parameter.
Public methodMakeReportingSet the family parameter as a reporting parameter.
Public methodMakeTypeSet the family parameter as a type parameter.
Public methodNewTypeAdd a new family type with a given name and makes it be the current type.
Public methodRemoveParameterRemove an existing family parameter from the family.
Public methodRenameCurrentTypeRename the current family type.
Public methodRenameParameterRename a family parameter.
Public methodReorderParameters 
Public methodReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean)Replace a family parameter with a shared parameter.
Public methodReplaceParameter(FamilyParameter, String, ForgeTypeId, Boolean)Replace a shared family parameter with a new non-shared family parameter.
Public methodSet(FamilyParameter, ElementId)Set the ElementId value of a family parameter of the current family type.
Public methodSet(FamilyParameter, Double)Set the double value of a family parameter of the current family type.
Public methodSet(FamilyParameter, Int32)Set the integer value of a family parameter of the current family type.
Public methodSet(FamilyParameter, String)Set the string value of a family parameter of the current family type.
Public methodSetDescriptionSet the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public methodSetFormulaSet the formula of a family parameter.
Public methodSetParameterLocked For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
Public methodSetValueStringSet the string value of a family parameter of the current family type.
Public methodSortParameters Sorts the family parameters according to the desired sort order.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also