FamilyManager.RenameCurrentType Method

FamilyManagerRenameCurrentType Method

Rename the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void RenameCurrentType(
	string typeName
)
Public Sub RenameCurrentType ( 
	typeName As String
)
public:
void RenameCurrentType(
	String^ typeName
)
member RenameCurrentType : 
        typeName : string -> unit 

Parameters

typeName  String
The new name of the current family type.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the input argument-"typeName"-is .
ArgumentException Thrown when the input argument-"typeName"-is already in use.
InvalidOperationException Thrown when the family type rename failed.
See Also