Revit 2025.3 API
Family |
Gets the parameters associated to family types in order.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public IList<FamilyParameter> GetParameters()
Public Function GetParameters As IList(Of FamilyParameter)
public: IList<FamilyParameter^>^ GetParameters()
member GetParameters : unit -> IList<FamilyParameter>
Return Value
IListFamilyParameterA collection containing all family parameters.

The parameters are family built-in parameters, category built-in parameters and shared parameters associated to the family types.
The collection consists of both visible and invisible parameters associated to the family types.
The parameters are returned in the order in which they appear in the Revit UI within a given group; however, parameters of different groups may be mixed within this output.
Currently the Revit UI order is determined first by group and next by the order of the individual parameters.
See Also