FamilyParameter Class

FamilyParameter Class

The family parameter object.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBFamilyParameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FamilyParameter : APIObject
Public Class FamilyParameter
	Inherits APIObject
public ref class FamilyParameter : public APIObject
type FamilyParameter = 
    class
        inherit APIObject
    end

The FamilyParameter type exposes the following members.

Properties
 NameDescription
Public propertyAssociatedParametersThe parameters from elements in the family which are associated to this parameter.
Public propertyCanAssignFormulaIndicates if this parameter can be assigned a formula.
Public propertyDefinitionThe definition.
Public propertyFormulaThe formula.
Public propertyGUIDThe globally unique identifier
Public propertyIdThe id of the family parameter.
Public propertyIsDeterminedByFormulaIndicates if the parameter is determined by formula.
Public propertyIsInstanceIndicates if the parameter is instance or type.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Overrides APIObjectIsReadOnly)
Public propertyIsReportingIndicates if the parameter is a reporting parameter.
Public propertyIsSharedIdentifies if the parameter is a shared parameter.
Public propertyStorageTypeThe storage type describes the type that is used internally within the parameter to store its value.
Public propertyUserModifiable Indicates whether the interactive user can modify the value of this parameter.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetUnitTypeIdGets the identifier of the unit quantifying the parameter value.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also