Revit 2025.3 API
Logical |
A filter that contains a set of filters. The filter passes when all filters in the set pass.

SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBLogicalAndFilter
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBLogicalAndFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The LogicalAndFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | LogicalAndFilter(IListElementFilter) | Initializes a new instance of the LogicalAndFilter class |
![]() | LogicalAndFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters. |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.
See Also