Revit 2025.3 API
Rebar |
This method changes the RebarShape of a Free Form Rebar that is using RebarWorkInstructions.Straight property to the provided RebarShape.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetReportedShape( ElementId rebarShapeId )
Public Sub SetReportedShape ( rebarShapeId As ElementId )
public: void SetReportedShape( ElementId^ rebarShapeId )
member SetReportedShape : rebarShapeId : ElementId -> unit
Parameters
- rebarShapeId ElementId

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | rebarShapeId cannot be set as a reporting RebarShape for this Rebar element. |

The Rebar element RebarWorkInstructions property should be Straight.
The rebarShapeId parameter should be the id of a straight RebarShape (single straight segment, no RebarHookType, no EndTreatmentType).
Moreover the straight RebarShape RebarStyle should match ( if the current RebarShape RebarStyle is Standard then the RebarShape cannot be changed to a straigh RebarShape using the RebarStyle Stirrup/Tie ).
If current RebarShape and the provided rebarShapeId has Stirrup/Tie RebarStyle then also the StirrupTieAttachmentType should match ( both InteriorFace or ExteriorFace ).
See Also