ExternalResourceTypes.BuiltInExternalResourceTypes Class

ExternalResourceTypesBuiltInExternalResourceTypes Class

A collection of ids of the ExternalResourceTypes provided by Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternalResourceTypesBuiltInExternalResourceTypes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class BuiltInExternalResourceTypes
Public NotInheritable Class BuiltInExternalResourceTypes
public ref class BuiltInExternalResourceTypes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BuiltInExternalResourceTypes = class end

The ExternalResourceTypesBuiltInExternalResourceTypes type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberAssemblyCodeTable An external resource type representing assembly code data.
Public propertyStatic memberCADLink An external resource type representing CAD Links data.
Public propertyStatic memberDecalBumpMap An external resource type representing Decal linked data for bump map. This type is reserved for future expansion but not yet implemented.
Public propertyStatic memberDecalCutOut An external resource type representing Decal linked data for cut out opacity. This type is reserved for future expansion but not yet implemented.
Public propertyStatic memberDecalImage An external resource type representing decal images.
Public propertyStatic memberDecalMap An external resource type representing Decal linked data for diffuse. This type is reserved for future expansion but not yet implemented.
Public propertyStatic memberDWFMarkup An external resource type representing DWF markups data. This type is reserved for future expansion but not yet implemented.
Public propertyStatic memberFabricationConfiguration An external resource type representing an MEP fabrication configuration.
Public propertyStatic memberIFCLink An external resource type representing IFC links.
Public propertyStatic memberImage An external resource type representing images.
Public propertyStatic memberKeynoteTable An external resource type representing keynote data.
Public propertyStatic memberMaterialTexture An external resource type representing material texture images.
Public propertyStatic memberPointCloud An external resource type representing Point Clouds. This type is reserved for future expansion but not yet implemented.
Public propertyStatic memberRevitLink An external resource type representing Revit Links data.
Public propertyStatic memberSystemsAnalysisReport An external resource type representing systems analysis report path.
Public propertyStatic memberTopographyLink An external resource type representing Topography Links.
Top
See Also