SpatialElementFromToCalculationPoints.FromPosition Property

SpatialElementFromToCalculationPointsFromPosition Property

The "from" position of spatial element connecting calculation point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ FromPosition { get; set; }
Public Property FromPosition As XYZ
	Get
	Set
public:
property XYZ^ FromPosition {
	XYZ^ get ();
	void set (XYZ^ value);
}
member FromPosition : XYZ with get, set

Property Value

XYZ
Exceptions
ExceptionCondition
ArgumentException When setting this property: fromPosition must be on the opposite side of the family's host from the "to" position.
ArgumentNullException When setting this property: A non-optional argument was null
See Also