SpatialElementFromToCalculationPoints.IsAcceptableFromPosition Method

SpatialElementFromToCalculationPointsIsAcceptableFromPosition Method

Checks whether a given "from" position is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsAcceptableFromPosition(
	XYZ fromPosition
)
Public Function IsAcceptableFromPosition ( 
	fromPosition As XYZ
) As Boolean
public:
bool IsAcceptableFromPosition(
	XYZ^ fromPosition
)
member IsAcceptableFromPosition : 
        fromPosition : XYZ -> bool 

Parameters

fromPosition  XYZ
 

Return Value

Boolean
True if the input is an acceptable "from" position and False otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
The "from" position and the "to" position must be on opposite sides of the family's host. Flipping the calculation point will reverse the direction.
See Also