BindingMap Class

BindingMap Class

The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBDefinitionBindingMap
      Autodesk.Revit.DBBindingMap

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class BindingMap : DefinitionBindingMap
Public Class BindingMap
	Inherits DefinitionBindingMap
public ref class BindingMap : public DefinitionBindingMap
type BindingMap = 
    class
        inherit DefinitionBindingMap
    end

The BindingMap type exposes the following members.

Properties
 NameDescription
Public propertyItem The get_Item method will get the binding item related to the input key.
(Overrides DefinitionBindingMapItemDefinition)
Top
Methods
 NameDescription
Public methodClearThis method is used to remove all the items in the map.
(Overrides DefinitionBindingMapClear)
Public methodContains The Contains method is used to check if the parameter binding exists for one definition.
(Overrides DefinitionBindingMapContains(Definition))
Public methodEraseThis method is used to erase one item in the map.
(Overrides DefinitionBindingMapErase(Definition))
Public methodInsert(Definition, Binding)Creates a new parameter binding between a parameter and a set of categories.
(Overrides DefinitionBindingMapInsert(Definition, Binding))
Public methodInsert(Definition, Binding, ForgeTypeId) Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public methodReInsert(Definition, Binding)Removes an existing parameter and creates a new binding for a given parameter.
Public methodReInsert(Definition, Binding, ForgeTypeId)Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public methodRemove The Remove method is used to remove a parameter binding.
Top
Remarks
The ParameterBindingsMap is available from the Document.ParameterBindings property. A parameter binding is the way that a parameter definition is bound to elements within one or more categories. This map can be used to interrogate existing bindings, but it can also be used to generate new parameter bindings by using the Insert method.
See Also