BindingMap Class

BindingMap Class

The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBDefinitionBindingMap
      Autodesk.Revit.DBBindingMap

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class BindingMap : DefinitionBindingMap
Public Class BindingMap
	Inherits DefinitionBindingMap
public ref class BindingMap : public DefinitionBindingMap
type BindingMap = 
    class
        inherit DefinitionBindingMap
    end

The BindingMap type exposes the following members.

Properties
 NameDescription
Public propertyIsEmptyTest to see if the map is empty.
(Inherited from DefinitionBindingMap)
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyItem The get_Item method will get the binding item related to the input key.
(Overrides DefinitionBindingMapItemDefinition)
Public propertySizeReturns the number of bindings that are in the map.
(Inherited from DefinitionBindingMap)
Top
Methods
 NameDescription
Public methodClearThis method is used to remove all the items in the map.
(Overrides DefinitionBindingMapClear)
Public methodContains The Contains method is used to check if the parameter binding exists for one definition.
(Overrides DefinitionBindingMapContains(Definition))
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEraseThis method is used to erase one item in the map.
(Overrides DefinitionBindingMapErase(Definition))
Public methodForwardIteratorRetrieve a forward moving iterator to the map.
(Inherited from DefinitionBindingMap)
Public methodGetEnumeratorRetrieve a forward moving iterator to the map.
(Inherited from DefinitionBindingMap)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsert(Definition, Binding)Creates a new parameter binding between a parameter and a set of categories.
(Overrides DefinitionBindingMapInsert(Definition, Binding))
Public methodInsert(Definition, Binding, ForgeTypeId) Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public methodReInsert(Definition, Binding)Removes an existing parameter and creates a new binding for a given parameter.
Public methodReInsert(Definition, Binding, ForgeTypeId)Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public methodRemove The Remove method is used to remove a parameter binding.
Public methodReverseIteratorRetrieve a backward moving iterator to the map.
(Inherited from DefinitionBindingMap)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The ParameterBindingsMap is available from the Document.ParameterBindings property. A parameter binding is the way that a parameter definition is bound to elements within one or more categories. This map can be used to interrogate existing bindings, but it can also be used to generate new parameter bindings by using the Insert method.
See Also