TrussMemberInfo Class

TrussMemberInfo Class

Provides access to the information of a truss member in Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureTrussMemberInfo

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TrussMemberInfo
Public Class TrussMemberInfo
public ref class TrussMemberInfo
type TrussMemberInfo = class end

The TrussMemberInfo type exposes the following members.

Constructors
 NameDescription
Public methodTrussMemberInfoFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyhostTrussIdThe host truss' ElementId of the member.
Public propertylockedToTrussWhether the member is locked to the host truss.
Public propertymemberTypeKeyKind of the member in the truss.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A struct TrussMemberInfo that contains an element's host truss, whether to lock to the truss, usage type, etc.
See Also