ViewCropRegionShapeManager.GetAnnotationCropShape Method

ViewCropRegionShapeManagerGetAnnotationCropShape Method

Gets the annotation crop box assigned to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public CurveLoop GetAnnotationCropShape()
Public Function GetAnnotationCropShape As CurveLoop
public:
CurveLoop^ GetAnnotationCropShape()
member GetAnnotationCropShape : unit -> CurveLoop 

Return Value

CurveLoop
The annotation crop boundary.
Exceptions
ExceptionCondition
InvalidOperationException View is not allowed to have an annotation crop.
Remarks
Currently, this method returns only the rectangular annotation crop box.
See Also