ViewCropRegionShapeManager Class

ViewCropRegionShapeManager Class

A class that provides access to settings related to the crop assigned to a view or a reference callout.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBViewCropRegionShapeManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ViewCropRegionShapeManager : IDisposable
Public Class ViewCropRegionShapeManager
	Implements IDisposable
public ref class ViewCropRegionShapeManager : IDisposable
type ViewCropRegionShapeManager = 
    class
        interface IDisposable
    end

The ViewCropRegionShapeManager type exposes the following members.

Properties
 NameDescription
Public propertyBottomAnnotationCropOffset The offset from the bottom of the view crop that determines the location of the annotation crop bottom boundary.
Public propertyCanBeSplit Verifies that the crop of the associated view is permitted to have multiple regions.
Public propertyCanHaveAnnotationCrop Verifies that the view is allowed to have an annotation crop.
Public propertyCanHaveShape Verifies that the crop of the associated view is permitted to have a non-rectangular shape.
Public propertyIsSplitHorizontally Whether or not the view's crop is split (and the split is horizontal).
Public propertyIsSplitVertically Whether or not the view's crop is split (and the split is vertical).
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLeftAnnotationCropOffset The offset from the left of the view crop that determines the location of the annotation crop left boundary.
Public propertyNumberOfSplitRegions The number of split crop regions (1 if the crop is not currently split).
Public propertyRightAnnotationCropOffset The offset from the right of the view crop that determines the location of the annotation crop right boundary.
Public propertyShapeSet Whether or not the view crop has a non-rectangular shape set.
Public propertySplit Whether or not the view crop is split.
Public propertyTopAnnotationCropOffset The offset from the top of the view crop that determines the location of the annotation crop top boundary.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ViewCropRegionShapeManager
Public methodGetAnnotationCropShape Gets the annotation crop box assigned to the view.
Public methodGetCropShape Gets the crop boundaries that are curently active.
Public methodGetSplitRegionMaximum Returns the proportional location of the maximum boundary of the specified split crop region.
Public methodGetSplitRegionMinimum Returns the proportional location of the minimum boundary of the specified split crop region.
Public methodGetSplitRegionOffset Returns the offset for the specified split crop region.
Public methodIsCropRegionShapeValid Verifies that boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Public methodRemoveCropRegionShape Removes any non-rectangular boundary of the view's crop.
Public methodRemoveSplit Removes any split applied to the view's crop.
Public methodRemoveSplitRegion Removes one region in split crop.
Public methodSetCropShape Sets the boundary of the view's crop to the specified shape.
Public methodSplitRegionHorizontally Splits horizontally one region in split crop.
Public methodSplitRegionVertically Splits vertically one region in split crop.
Top
Remarks

This class manages all the settings that make up the model and annotation crop geometry for a given view or reference callout. You can obtain the settings for a view from GetCropRegionShapeManager. Obtain the settings for a reference callout from GetCropRegionShapeManagerForReferenceCallout(Document, ElementId).

The model crop region crops model elements, detail elements (such as insulation and detail lines), section boxes, and scope boxes at the model crop boundary. Visible crop boundaries of other related views are also cropped at the model crop boundary. The model crop region can be set as a polygonal boundary, a rectangular boundary, or rectangular boundary with one or more splits applied either horizontally or vertically. If a split is applied to the rectangular crop each resulting rectangular region is identified by a region index and occupies a percentage of the original crop rectangle. The regions may possibly be moved relative to one another.

The annotation crop region fully crops annotation elements when it touches any portion of the annotation element, so that no partial annotations are drawn. Annotations (such as symbols, tags, keynotes, and dimensions) that reference hidden or cropped model elements do not display in the view, even if they are inside the annotation crop region. The annotation crop region is always rectangular and at minimum occupies the same area as the rectangular model crop (or the corresponding rectangular boundary around the non-rectangular model crop), but can be offset to be bigger than the model crop in order to display more annotations.

See Also