Revit 2025.3 API
CurveCreate |
Crates a new instance of a curve as a transformation of this curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Curve CreateTransformed( Transform transform )
Public Function CreateTransformed ( transform As Transform ) As Curve
public: Curve^ CreateTransformed( Transform^ transform )
member CreateTransformed : transform : Transform -> Curve
Parameters
- transform Transform
- The transform to apply.
Return Value
CurveThe new curve.

Exception | Condition |
---|---|
ArgumentException | transform is not conformal. |
ArgumentNullException | A non-optional argument was NULL |
See Also