RebarShapeSegment Class

RebarShapeSegment Class

Part of a RebarShapeDefinitionBySegments, representing one segment of a shape definition. Makes sure constraints of type RebarShapeConstraintFixedSegmentDir are uniquely set. If we try to aquire a second constraint of type RebarShapeConstraintFixedSegmentDir we delete the old one.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureRebarShapeSegment

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RebarShapeSegment : IDisposable
Public Class RebarShapeSegment
	Implements IDisposable
public ref class RebarShapeSegment : IDisposable
type RebarShapeSegment = 
    class
        interface IDisposable
    end

The RebarShapeSegment type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RebarShapeSegment
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetConstraints Retrieve the list of constraints associated with this segment.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetConstraints 
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

Each segment must have enough constraints to determine its position. Overconstraining is allowed. The most common combinations are:

  • A fixed direction together with a parallel length constraint;
  • A parallel length constraint plus another length constraint parallel to the x-axis or y-axis;
  • A parallel length constraint plus length constraints parallel to both the x-axis and y-axis.
Multiple constraints may be driven by the same parameter, even on the same segment.

Length constraints may be measured in two ways. For "measured to the outside of the bend," the reference is a tangent to the exterior face of the bar; the thickness of the bar is included. For "measured to the inside," the reference is the center of the arc of the bend; this is the point where the bend begins, if the constraint is parallel to the segment.

A 180-degree bend is described by introducing a short segment in between the two straight segments, tangent to the midpoint of the bend.

See Also