Revit 2025.3 API
Schedule |
Checks whether a field ID would create a circular chain of references
when used by the PercentageOf property of this field.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool CreatesCircularReferences( ScheduleFieldId fieldId )
Public Function CreatesCircularReferences ( fieldId As ScheduleFieldId ) As Boolean
public: bool CreatesCircularReferences( ScheduleFieldId^ fieldId )
member CreatesCircularReferences : fieldId : ScheduleFieldId -> bool
Parameters
- fieldId ScheduleFieldId
- The field ID to check.
Return Value
BooleanTrue if the field ID would create a circular chain of references, false otherwise.

Exception | Condition |
---|---|
ArgumentException | fieldId is not InvalidScheduleFieldId or the ID of a field that can be used to calculated percentages. |
ArgumentNullException | A non-optional argument was null |
See Also