Revit 2025.3 API
Rebar |
Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetAllowed( RebarBarType barType, bool allowed )
Public Sub SetAllowed ( barType As RebarBarType, allowed As Boolean )
public: void SetAllowed( RebarBarType^ barType, bool allowed )
member SetAllowed : barType : RebarBarType * allowed : bool -> unit
Parameters
- barType RebarBarType
- A bar type in the same document as this shape.
- allowed Boolean
- Whether this shape may be combined with barType.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also