FamilySizeTableErrorInfo Class

FamilySizeTableErrorInfo Class

Error information generated from the CSV file import of a FamilySizeTable.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFamilySizeTableErrorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FamilySizeTableErrorInfo : IDisposable
Public Class FamilySizeTableErrorInfo
	Implements IDisposable
public ref class FamilySizeTableErrorInfo : IDisposable
type FamilySizeTableErrorInfo = 
    class
        interface IDisposable
    end

The FamilySizeTableErrorInfo type exposes the following members.

Constructors
 NameDescription
Public methodFamilySizeTableErrorInfo Constructs a new FamilySizeTableErrorInfo with default settings.
Top
Properties
 NameDescription
Public propertyFamilySizeTableErrorType The error type.
Public propertyFilePath The path of the imported CSV file.
Public propertyInvalidColumnIndex The index of the invalid column.
Public propertyInvalidHeaderText The invalid header text.
Public propertyInvalidRowIndex The index of the invalid row.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FamilySizeTableErrorInfo
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also