Asset Class

Asset Class

Represents a connected property of material.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.VisualAssetProperty
    Autodesk.Revit.DB.VisualAssetProperties
      Autodesk.Revit.DB.VisualAsset

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Asset : AssetProperties
Public Class Asset
	Inherits AssetProperties
public ref class Asset : public AssetProperties
type Asset = 
    class
        inherit AssetProperties
    end

The Asset type exposes the following members.

Properties
 NameDescription
Public propertyAssetType The type of RenderingAsset
Public propertyLibraryName Library name
Public propertyTitle Asset title
Top
Methods
 NameDescription
Top
See Also