ConnectionValidationWarning Class

ConnectionValidationWarning Class

Contains information about a specific connection validation problem.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBConnectionValidationWarning

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ConnectionValidationWarning : IDisposable
Public Class ConnectionValidationWarning
	Implements IDisposable
public ref class ConnectionValidationWarning : IDisposable
type ConnectionValidationWarning = 
    class
        interface IDisposable
    end

The ConnectionValidationWarning type exposes the following members.

Constructors
 NameDescription
Public methodConnectionValidationWarning Constructor.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyReason Enumeration for reason of warning.
Public propertyResolution Enumeration for resolution that was applied.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ConnectionValidationWarning
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetParts Get ElementIds of affected parts.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also