Revit 2025.3 API
External |
Adds an external resource to the folder path by supplying the resource name and version.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void AddResource( string resourceName, string version )
Public Sub AddResource ( resourceName As String, version As String )
public: void AddResource( String^ resourceName, String^ version )
member AddResource : resourceName : string * version : string -> unit
Parameters
- resourceName String
- The unique short name of external resource.
- version String
- The version of external resource.

Exception | Condition |
---|---|
ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259. |
ArgumentNullException | A non-optional argument was null |
See Also