IExport |
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
RenderNodeAction OnCurve( CurveNode node )
Function OnCurve ( node As CurveNode ) As RenderNodeAction
RenderNodeAction OnCurve( CurveNode^ node )
abstract OnCurve : node : CurveNode -> RenderNodeAction
Parameters
- node CurveNode
- An output node that represents a Curve.
Return Value
RenderNodeActionReturn RenderNodeAction.Proceed if you wish to receive tessellated geometry (line or polyline segments) for this curve, or otherwise return RenderNodeAction.Skip.
Note for 2D export: if the export is performed for the view in non-Wireframe display style tesselated geometry will be output regardless of the return value.

Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.
The curve can be one of the geometric object that derive from the Curve class, e.g. Line, Arc, NurbeSpline, etc. To get to the specific properties of the particular class, the curve obtained from the input node first needs to be cast accordingly depending on the curve's actual type.
Note for 2D export: if the export is performed for the view in non-Wireframe display style this method will be called regardless of whether the object will be eventially output, i.e. even if it's occluded by another element.