IExportContextBase Interface

IExportContextBase Interface

An interface that as common base for IModelExportContext and IExportContext2D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public interface IExportContextBase : IExportContext
Public Interface IExportContextBase
	Inherits IExportContext
public interface class IExportContextBase : IExportContext
type IExportContextBase = 
    interface
        interface IExportContext
    end

The IExportContextBase type exposes the following members.

Methods
 NameDescription
Public methodFinish This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).
(Inherited from IExportContext)
Public methodIsCanceled This method is queried at the beginning of every element.
(Inherited from IExportContext)
Public methodOnCurve This method is called when a Curve is being output.
Public methodOnElementBegin This method marks the beginning of an element to be exported.
(Inherited from IExportContext)
Public methodOnElementEnd This method marks the end of an element being exported.
(Inherited from IExportContext)
Public methodOnFaceBegin This method marks the beginning of a Face to be exported.
(Inherited from IExportContext)
Public methodOnFaceEnd This method marks the end of the current face being exported.
(Inherited from IExportContext)
Public methodOnInstanceBegin This method marks the start of processing of an instance node (e.g. a family instance).
(Inherited from IExportContext)
Public methodOnInstanceEnd This method marks the end of processing of an Instance Node (e.g. a family instance).
(Inherited from IExportContext)
Public methodOnLight This method marks the beginning of export of a light which is enabled for rendering.
(Inherited from IExportContext)
Public methodOnLineSegment This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

Public methodOnLinkBegin This method marks the beginning of a link instance to be exported.
(Inherited from IExportContext)
Public methodOnLinkEnd This method marks the end of a link instance being exported.
(Inherited from IExportContext)
Public methodOnMaterial This method marks a change of the material.
(Inherited from IExportContext)
Public methodOnPolyline This method is called when a Polyline is being output.
Public methodOnPolylineSegments This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

Public methodOnPolymesh This method is called when a tessellated polymesh of a 3d face is being output.
(Inherited from IExportContext)
Public methodOnRPC This method marks the beginning of export of an RPC object.
(Inherited from IExportContext)
Public methodOnText This method is called when a text annotation object is being output.
Public methodOnViewBegin This method marks the beginning of a 3D view to be exported.
(Inherited from IExportContext)
Public methodOnViewEnd This method marks the end of a 3D view being exported.
(Inherited from IExportContext)
Public methodStart This method is called at the very start of the export process, still before the first entity of the model was send out.
(Inherited from IExportContext)
Top
See Also