Revit 2025.3 API
IExport |
This method marks the beginning of export of an RPC object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
void OnRPC( RPCNode node )
Sub OnRPC ( node As RPCNode )
void OnRPC( RPCNode^ node )
abstract OnRPC : node : RPCNode -> unit
Parameters
- node RPCNode
- A node with asset information about the RPC object.

This method is only called for photo-rendering export (a custom exporter that implements IPhotoRenderContext).
When an RPC object is encountered for a model context export (a custom exporter that implements IModelExportContext),
the RPC object will be provided as a polymesh (via OnPolymesh(PolymeshTopology)).
See Also