IPhotoRenderContext Interface

IPhotoRenderContext Interface

An interface that is used in custom export to render 3D views of a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public interface IPhotoRenderContext : IExportContext
Public Interface IPhotoRenderContext
	Inherits IExportContext
public interface class IPhotoRenderContext : IExportContext
type IPhotoRenderContext = 
    interface
        interface IExportContext
    end

The IPhotoRenderContext type exposes the following members.

Methods
 NameDescription
Public methodFinish This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).
(Inherited from IExportContext)
Public methodIsCanceled This method is queried at the beginning of every element.
(Inherited from IExportContext)
Public methodOnElementBegin This method marks the beginning of an element to be exported.
(Inherited from IExportContext)
Public methodOnElementEnd This method marks the end of an element being exported.
(Inherited from IExportContext)
Public methodOnFaceBegin This method marks the beginning of a Face to be exported.
(Inherited from IExportContext)
Public methodOnFaceEnd This method marks the end of the current face being exported.
(Inherited from IExportContext)
Public methodOnInstanceBegin This method marks the start of processing of an instance node (e.g. a family instance).
(Inherited from IExportContext)
Public methodOnInstanceEnd This method marks the end of processing of an Instance Node (e.g. a family instance).
(Inherited from IExportContext)
Public methodOnLight This method marks the beginning of export of a light which is enabled for rendering.
(Inherited from IExportContext)
Public methodOnLinkBegin This method marks the beginning of a link instance to be exported.
(Inherited from IExportContext)
Public methodOnLinkEnd This method marks the end of a link instance being exported.
(Inherited from IExportContext)
Public methodOnMaterial This method marks a change of the material.
(Inherited from IExportContext)
Public methodOnPolymesh This method is called when a tessellated polymesh of a 3d face is being output.
(Inherited from IExportContext)
Public methodOnRPC This method marks the beginning of export of an RPC object.
(Inherited from IExportContext)
Public methodOnViewBegin This method marks the beginning of a 3D view to be exported.
(Inherited from IExportContext)
Public methodOnViewEnd This method marks the end of a 3D view being exported.
(Inherited from IExportContext)
Public methodStart This method is called at the very start of the export process, still before the first entity of the model was send out.
(Inherited from IExportContext)
Top
Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The interface methods are then called at times of rendering entities that are currently visible in the view being rendered.

With this type of export context used to perform a custom export, Revit will traverse the model and output the model's geometry as if processing the Render command invoked via the UI. It means that only such elements that have actual geometry and are suitable to appear in a rendered view will be processed and output.

See Also