IExportContext.OnLight Method

IExportContextOnLight Method

This method marks the beginning of export of a light which is enabled for rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
void OnLight(
	LightNode node
)
Sub OnLight ( 
	node As LightNode
)
void OnLight(
	LightNode^ node
)
abstract OnLight : 
        node : LightNode -> unit 

Parameters

node  LightNode
A node describing the light object.
Remarks
This method is only called for photo-rendering export (a custom exporter that implements IPhotoRenderContext).
See Also