Revit 2025.3 API
DocumentIs |
Checks if the element's face is painted with a material.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsPainted( ElementId elementId, Face face )
Public Function IsPainted ( elementId As ElementId, face As Face ) As Boolean
public: bool IsPainted( ElementId^ elementId, Face^ face )
member IsPainted : elementId : ElementId * face : Face -> bool
Parameters
Return Value
BooleanTrue if the element's face is painted.

Exception | Condition |
---|---|
ArgumentException | The element elementId does not exist in the document -or- The face doesn't belong to the element |
ArgumentNullException | A non-optional argument was null |
See Also