Document.GetRoomAtPoint(XYZ) Method

DocumentGetRoomAtPoint(XYZ) Method

Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Room GetRoomAtPoint(
	XYZ point
)
Public Function GetRoomAtPoint ( 
	point As XYZ
) As Room
public:
Room^ GetRoomAtPoint(
	XYZ^ point
)
member GetRoomAtPoint : 
        point : XYZ -> Room 

Parameters

point  XYZ
Point to be checked.

Return Value

Room
The room containing the point.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the point is .
ArgumentException Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.
Remarks
Surveys only the rooms from the final phase of the project. The first one found will be returned. If there is no room containing the point, it returns .
See Also