Revit 2025.3 API
Value |
A base class representing storage of values at a given point.

SystemObject
Autodesk.Revit.DBValueAtPointBase
Autodesk.Revit.DB.AnalysisValueAtPoint
Autodesk.Revit.DB.AnalysisVectorAtPoint
Autodesk.Revit.DBValueAtPointBase
Autodesk.Revit.DB.AnalysisValueAtPoint
Autodesk.Revit.DB.AnalysisVectorAtPoint
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The ValueAtPointBase type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | ClearAllFlags | Sets flags for all measurements to ValueAtPointFlags::None. |
![]() | ClearFlagsAt | Sets flags for the given measurement to ValueAtPointFlags::None. |
![]() | Dispose | Releases all resources used by the ValueAtPointBase |
![]() | GetFlags | Returns flags for the given measurement. |
![]() | SetFlags(IListInt32) | |
![]() | SetFlags(Int32) | Sets the flags associated to all measurements to the same value. |
![]() | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement. |

This class stores a set of measurements and corresponding mapped flags.
The flags are defined in the enumerated type ValueAtPointFlags.
See Also