CurveElement.LineStyle Property

CurveElementLineStyle Property

The line style of this curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Element LineStyle { get; set; }
Public Property LineStyle As Element
	Get
	Set
public:
property Element^ LineStyle {
	Element^ get ();
	void set (Element^ value);
}
member LineStyle : Element with get, set

Property Value

Element
Exceptions
ExceptionCondition
ArgumentNullException Thrown when argument is .
InvalidOperationException Thrown when regeneration failed. -- or -- Thrown when fail to get line style.
Remarks
The return of this property will be a GraphicsStyle element. These graphics styles should be associated to subcategories of the BuiltInCategory OST_Lines.
See Also