TableSectionData.GetCellFormatOptions(Int32, Document) Method

TableSectionDataGetCellFormatOptions(Int32, Document) Method

Returns a column's cell FormatOptions and if no FormatOptions exists for this column, it would come from the section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public FormatOptions GetCellFormatOptions(
	int nCol,
	Document dcument
)
Public Function GetCellFormatOptions ( 
	nCol As Integer,
	dcument As Document
) As FormatOptions
public:
FormatOptions^ GetCellFormatOptions(
	int nCol, 
	Document^ dcument
)
member GetCellFormatOptions : 
        nCol : int * 
        dcument : Document -> FormatOptions 

Parameters

nCol  Int32
 
dcument  Document
 

Return Value

FormatOptions
Exceptions
ExceptionCondition
ArgumentException The given column number nCol is invalid.
ArgumentNullException A non-optional argument was null
See Also