TessellatedFace Class

TessellatedFace Class

Defines a planar face bounded by a polyline in 3d space. A face consists of a single connected component and can have holes.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBTessellatedFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TessellatedFace : IDisposable
Public Class TessellatedFace
	Implements IDisposable
public ref class TessellatedFace : IDisposable
type TessellatedFace = 
    class
        interface IDisposable
    end

The TessellatedFace type exposes the following members.

Constructors
 NameDescription
Public methodTessellatedFace(IListXYZ, ElementId)Initializes a new instance of the TessellatedFace class
Public methodTessellatedFace(IListIListXYZ, ElementId)Initializes a new instance of the TessellatedFace class
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMaterialId Material of the face.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the TessellatedFace
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBoundaryLoops Get loops bounding the face.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also