ViewShapeBuilder.ValidateShape Method

ViewShapeBuilderValidateShape Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool ValidateShape(
	IList<GeometryObject> shape,
	DirectShapeTargetViewType targetViewType
)
Public Shared Function ValidateShape ( 
	shape As IList(Of GeometryObject),
	targetViewType As DirectShapeTargetViewType
) As Boolean
public:
static bool ValidateShape(
	IList<GeometryObject^>^ shape, 
	DirectShapeTargetViewType targetViewType
)
static member ValidateShape : 
        shape : IList<GeometryObject> * 
        targetViewType : DirectShapeTargetViewType -> bool 

Parameters

shape  IListGeometryObject
 
targetViewType  DirectShapeTargetViewType
 

Return Value

Boolean
See Also