Revit 2025.3 API
DocumentGet |
Gets a space containing the point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Space GetSpaceAtPoint( XYZ point )
Public Function GetSpaceAtPoint ( point As XYZ ) As Space
public: Space^ GetSpaceAtPoint( XYZ^ point )
member GetSpaceAtPoint : point : XYZ -> Space
Parameters
- point XYZ
- Point to be checked.
Return Value
SpaceThe space containing the point.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the point is . |
ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue. |

Surveys only the spaces from the final phase of the project. The first one found will be returned. If there is no space containing the point, it returns .
See Also