Revit 2025.3 API
Multi |
Determine whether two Grids are members of the same GridChain.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool AreGridsInSameMultiSegmentGrid( Grid grid1, Grid grid2 )
Public Shared Function AreGridsInSameMultiSegmentGrid ( grid1 As Grid, grid2 As Grid ) As Boolean
public: static bool AreGridsInSameMultiSegmentGrid( Grid^ grid1, Grid^ grid2 )
static member AreGridsInSameMultiSegmentGrid : grid1 : Grid * grid2 : Grid -> bool
Parameters
Return Value
BooleanReturns true if both of the specified Grids are associated to the same MultiSegmentGrid, i.e. getMultiSegementGridId returns the same valid element id for both Grids.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also