Revit 2025.3 API
Free |
Offsets a planar face of the free form element a certain distance in the normal direction.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetFaceOffset( Face face, double offset )
Public Sub SetFaceOffset ( face As Face, offset As Double )
public: void SetFaceOffset( Face^ face, double offset )
member SetFaceOffset : face : Face * offset : float -> unit
Parameters
- face Face
- The face to offset.
- offset Double
- The magnitude of the offset. A positive value offsets out of the input solid. A negative value offsets into the solid shape.

Exception | Condition |
---|---|
ArgumentException | face does not belong to the solid. -or- The face to be offset should be planar and satisfy constraints of its parent element. |
ArgumentNullException | A non-optional argument was null |
See Also