Revit 2025.3 API
Parameter |
Gets the ForgeTypeId identifying the built-in parameter corresponding to the given BuiltInParameter value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ForgeTypeId GetParameterTypeId( BuiltInParameter builtInParam )
Public Shared Function GetParameterTypeId ( builtInParam As BuiltInParameter ) As ForgeTypeId
public: static ForgeTypeId^ GetParameterTypeId( BuiltInParameter builtInParam )
static member GetParameterTypeId : builtInParam : BuiltInParameter -> ForgeTypeId
Parameters
- builtInParam BuiltInParameter
- The BuiltInParameter value.
Return Value
ForgeTypeIdIdentifier of the parameter corresponding to the given BuiltInParameter value.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
See Also