ParameterUtils Class

ParameterUtils Class

A utility class of functions related to parameters.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBParameterUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class ParameterUtils
Public NotInheritable Class ParameterUtils
public ref class ParameterUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ParameterUtils = class end

The ParameterUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberDownloadCompanyName Downloads the name of the given parameter's owning account and records it in the given document. If the owning account's name is already recorded in the given document, this method returns the name without downloading it again.
Public methodStatic memberDownloadParameter Create a shared parameter element in the given document according to a parameter definition downloaded from the Parameters Service.
Public methodStatic memberDownloadParameterOptions Retrieves settings associated with the given parameter from the Parameters Service.
Public methodStatic memberGetAllBuiltInGroups Gets the identifiers of all built-in parameter groups.
Public methodStatic memberGetAllBuiltInParameters Gets the identifiers of all built-in parameters.
Public methodStatic memberGetBuiltInParameter Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.
Public methodStatic memberGetParameterTypeId Gets the ForgeTypeId identifying the built-in parameter corresponding to the given BuiltInParameter value.
Public methodStatic memberIsBuiltInGroup Checks whether a ForgeTypeId identifies a built-in parameter group.
Public methodStatic memberIsBuiltInParameter(ElementId) Checks whether an ElementId identifies a built-in parameter.
Public methodStatic memberIsBuiltInParameter(ForgeTypeId) Checks whether a ForgeTypeId identifies a built-in parameter.
Top
See Also