Revit 2025.3 API
Parameter |
Checks whether an ElementId identifies a built-in parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsBuiltInParameter( ElementId parameterId )
Public Shared Function IsBuiltInParameter ( parameterId As ElementId ) As Boolean
public: static bool IsBuiltInParameter( ElementId^ parameterId )
static member IsBuiltInParameter : parameterId : ElementId -> bool
Parameters
- parameterId ElementId
- The identifier to check.
Return Value
BooleanTrue if the ElementId identifies a built-in parameter, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

An ElementId identifies a built-in parameter if it corresponds to a valid BuiltInParameter value.
See Also